[Logo] Anarduino and HopeRF Community Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics     [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: ntasher
Forum Index » Profile for ntasher » Messages posted by ntasher
Author Message
I'm stumped.
I managed to program some of my MiniWireless (about half of the 8 I have). Half of them will not program. I suspect two of them have dead AVRs for some reason (ordered new AVRs and will replace). One has a working AVR - it runs my code just fine. However, I cannot burn a bootloader. Got an AVR DRAGON (which has level shifters) and it wouldn't detect the AVR. Pulled D10 up. Even pulled D5 up just in case. Looking at the ISP siganls with a logic analyzer I can see SCK and MOSI toggling but MISO stays high. RST goes high to low before transaction and back up afterwards.
What am I missing here? I must have a watchdog-enabled bootloader for my projects - the RFM69 libraries have some RAM leakage that I didn't manage to trace and a watchdog is essential...
This one occurred to me when looking for ways to use the internal watchdog. Since I had issues with bootloader programming (since resolved) I wanted something else that would allow me to have some means of resetting a naughty processor. I had a great idea - use the RTC alarm output pin for that purpose. The RTC can be set to trigger an alarm at a specific time (minute or second or hour or combination of them). So I basically read the current seconds reading, set ALARM0 to N seconds away, set the output pin to go low on alarm tigger, and connect the alarm pin (also going to D3) to the RST pin via a 1uF capacitor. If I don't update the RTC alarm time every so often, the alarm will go off, pulling the RST low via the capacitor, resetting the CPU.
Note that the 1uF capacitor needs to be removed when connecting the board to the PC for code download.
I tried to program the bootloader by using two miniwireless boards - one functioning as ArduinoISP (a process I've done many times with many type of Arduinos) and it failed.
One board is driven by a CP2101 connected to the PC USB. I run the 5V from the CP2101 to both boards, program the connected one with ArduinoISP sketch, and then run wires between the boards:
Not working. I get this error message:
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

What gives?
PS. tried to program a miniwireless with an Uno at first. Got the same message. Suspected 3.3V/5V compatibility issues. Wrong direction.

Forum Index » Profile for ntasher » Messages posted by ntasher
Go to:   
Powered by JForum 2.1.9 © JForum Team