[Logo] Anarduino and HopeRF Community Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics     [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: JimKernsJr
Forum Index » Profile for JimKernsJr » Messages posted by JimKernsJr
Author Message
Hi All...

Just an update...

Programming it inline works OK, and I even accidentally discovered it even verifies OK without the pullup resistors. So, as luck with have it, I did not fry the radio.
So it makes sense that I fried the receive line on the header, and the transmit still works because it's output. What doesnt make sense is why it would not program under Windows when it was new.

I'll place an order for another and see what happens...

Many thanks again for everyone's help and input.

Best regards
Hi Greg...

Thanks for your reply and suggestion-it worked ok to burn a new bootloader. BTW, my crappy FTDI is not Ricks, I had it left over from another project.

Also, of course you were correct, it wasn't the bootloader, so still no luck uploading after burning a new bootloader to board 1 (The one with no test sketch anymore).

So I decided to put a serial test sketch back on him since I already had him hooked up to my UNO to do the bootloader. So, test sketch goes up fine, and light starts blinking - He's alive! Move my FTDI to the serial port, and he's talking! Out of curiosity, I take him to my Linux machine, still cant upload a sketch.

So now I think I know what has happened...I think I blew up the serial in line. I am very confused about the voltage levels of this thing. My Pro Mini is a 3.3, and at first I thought this thing was too. Reason - the onboard radio is 3.3, so I was sure it didnt have level converters - made more sense it was a 3.3 promini with a RFM69 and the voltage regulator at the beginning. But in your earlier post, you say use a 5v 328 board to program it AND a 16mhz chip is supposed to be 5v - so I've had had the jumper on the programmer at 5v.

So now my question to you guys (if I should have been using 3.3 for the data lines):
-do you think this is what happened?
-according to the wiring diagram, only VIN pin goes through the MCP 1703?? Even the programming header is tied to VCC which should have been 3.3v. Think I screwed up the radio now too?
-I think I did a very bad thing even burning the bootloader and uploading a sketch to it with my UNO that is not selectable (5v)
-Again, if he's 3.3v, how on earth is it 16mhz? I thought that would be a stability problem.

And if I was OK using the 5.5, what could be the problem...because now I'm really at a loss.

However, I will say, at this point I am OK uploading my sketches through ISP and if I need serial debug to hook up the FTDI...this is an OK workaround, although cumbersome.

Many thanks to you both. I am just really struggling with the combination of that I am relatively "green" with circuits, and the documentation is a little bit sparse and buggy! I've been a programmer for 15 years now...I thought this would come a little easier to me!
Hi All...

I have news....

I tried Greg's suggestion - no luck, because I'm sure I had also tried that out of desperation in past!

My new Anarduino showed up the other day, and I just tonight had a chance to work with him. I solder up just his connector for FTDI, and what a surprise, nothing works still.
So, scratching my head, I'm certain there's no way I have 2 bad ones. I move the whole setup from my windows 10 laptop to windows 7...still no luck. Then I think I read somewhere about driver problems...crappy Windows...crappy FTDI with non genuine chip...blah blah...so I try it on my Ubuntu laptop. First shot...it works!, turned on a couple serial tests, he talks ok! Move the whole deal still all plugged together back to Windows...no luck, with 7 or 10. Must be the driver - but what baffles me is that I can upload from Windows 10 through this same board to the Pro Mini??? My pro-mini is 3.3v...but still all it is is moving the jumper and change the setting.

Back to Ubuntu to do some other un-realated things...try and upload...FAIL. What the heck!!?? Turn on serial monitor...he's still alive talking on the serial port, but he wont take an upload.

Think the bootloaders are getting messed up? I don/t know how else to explain #2 board.

And by the way, the LED is on pin 9, not 13 like the schematic shows...
And of course Rick is correct, Duemilanove with ATmega328P 16Mhz works, and Greg is correct as well, pro mini 5V 16 MHz also works.

@Rick...I'd try what you said, but I saw you message too late when I uploaded blink on #2...but it worked anyway so I'm sure #2 is OK and #1 probably still is as well, I just cant confirm without a program. So knowing this, do you think I can reflash a new bootloader to them with this procedure:


However, is the RF69 board going to get in the way on pins 13,12 and 11 and stop me, or is it OK because he's not initialized?

Many thanks for all your help!
Best regards,

I hope you all can help me or offer some advice. I am the new proud over of the very neat Anarduino MiniWireless with RFM69HW radio. Unfortunately, I am having a fit uploading anything to it with much of any rate of success.

I believe it came with the blink sketch, so as I am working on the Home Automation Arduino project that almost everyone else is, I uploaded my shiny new node sketch to this board. The first time, I cant say I remember it going up flawless, but I believe it did work. Doing some troubleshooting, I needed to enable the serial debug in the sketch, and tried to upload again. And this is where it went south. In about 30 tries, I never could get it to upload again. I wondered if maybe there was some trouble with the code, as my gateway sketch actually seemed to take out a bootloader in one instance, I tried to put blink back on, and nothing...same failure rate. So I gave up for the night, and did lots of research.

I came back to it the next day, trying again to get blink back on it. I tried these recommendations from another thread:

Tools > Board > Arduino Pro or Pro Mini
and then set:
Tools > Processor > ATmega328 3.3V 8 MHz

and also
Tools > Board > Arduino Nano
Tools > Processor > ATmega 328.

I believe #2 worked at some point, because I got blink back on!!!

Unfortunately, I have never again been able to upload another sketch not matter what I choose. I even tried Rick's suggestion from the other thread:
"If you are using the Arduino IDE, you would choose Duemilanove with ATmega328P 16Mhz."

Unfortunately, no luck.

Ive tried:
-another FTDI programmer...I am using FT232RL jumpered to 3.3v on both. Ive tried 5v, because according to Rick it will work OK through the regulation.
-uploading to my Pro Mini 3.3 with both programmers - success rate 100%
-double, triple and quadruple checked the wiring...however I never unhooked it and it worked the first time and one time thereafter!
-tried the reset button deal at various stages before the upload.

So you can double check me:
Anarduino - Programmer
D1 - RX
D0 - TX
+V - VCC
N/C - CTS (no conn)

I should also mention - this thing has NEVER given me the "upload complete" message - even when it did work. I don't know what to make of that. Of course I have DTR hooked up to DTR on the programmer

I went ahead ordered a second one, we shall see how I do with it. But as for this board, anyone have any ideas?

Forum Index » Profile for JimKernsJr » Messages posted by JimKernsJr
Go to:   
Powered by JForum 2.1.9 © JForum Team